Warcraft 3 on Windows 7: how to fix cinematics and get Battle.net updates to work

On Windows 7, automatic updates of Warcraft 3 don’t work like normal, and the cinematics don’t show up – rather, you only hear the audio. This is how to fix it.

This took a small bit of googling to find; I’ll add my own version of how to do this below.


Assuming that Warcraft 3 was installed normally (i.e. to the Program Files folder):

  1. Run Warcraft 3 as an administrator and connect to Battle.net; this will download the latest updates.

    Result: game gets updated, and cinematics display, however they are ugly and basically washed out.

  2. Right click on the shortcut you use for launching Warcraft 3, and then select Properties. In the next window, select the Compatibility tab at the top, then check “Disable desktop composition”.

    Result: cinematics now display normally.

Please note: manually registering codecs should not be necessary, nor should you need to adjust gamma settings specifically for Warcraft 3.

Tested on: Windows 7 64-bit with Intel HD Graphics 4000.

NOTE: I don’t know whether downloading maps, etc., works as expected or if this also gives errors if not run as administrator. Either always run Warcraft 3 as the administrator, or relocate the installation folder to an unprotected location. (Other web pages out there tell how to do this; I haven’t done this myself.)

Hope this helps someone out there…

23 thoughts on “Warcraft 3 on Windows 7: how to fix cinematics and get Battle.net updates to work

  • I have Intel HD Graphics 3000, and i did everything listed and still i get a black screen when video is playing i can’t see the video.

    • That’s unfortunate… I think when I googled for a fix, someone suggested moving the Warcraft 3 folder someplace other than Program Files. Don’t remember why. You could try that…
      Otherwise, I know we aren’t alone on this issue; keep googling! And if you happen to find something that does work for you, a comment back here would be much appreciated. 🙂

  • guys i have such a question, i see black screen but with sound. i tried to reinstall, i tried to update the drivers, the version of warcraft without any succes please help

  • Sounds like a different issue… I have no idea. You’re better off asking at Blizzard’s forums or searching elsewhere. Sorry 🙁

  • My menu doesn’t show, it just plays the sound, and i can click the buttons. What this may be..?! Please help? (My pc can run the game smoothly, but i can’t pass this problem after deinstalling and installing after some time.

  • can someone please help i hae tried everything of the listed above, i already have the latest version 1.26. I have spent a whole day trying to find a fix by googling it and reinstalling and i can’t find one that works for me. it seems disabling desctop composion works for most people but not for me . Please help. Gladly appreciated

  • The K-lite Codecs worked for me!!! I did all the steps and nothing worked except that (I even for some reason installed the cccp one 1st- didn’t work either).
    So in all I have it under compatibility mode for xp sp3, desktop composition checked and running as admin. After I installed the K-lite, all was well.
    FOR THE HORDE!

  • Many problems of games in windows 7 may be fixed by selecting the compatibility mode to Windows xp (pack 3)… at least that works for me

  • I do not know if it’s just me or if perhaps everybody
    else encountering issues with your site. It appears like some of the
    text on your content are running off the screen. Can
    somebody else please comment and let me know if this is happening to them too?
    This may be a issue with my internet browser because I’ve had
    this happen previously. Thank you

  • ***Confirmed Windows 7 – 32 bit using latest patch and K-LITE CODEC PACK (BASIC)***
    Updated my version via this link and choosing Warcraft III (or whatever your game is):
    https://eu.battle.net/support/en/article/classic-game-patches
    Then download K-LITE CODEC PACK (you only need the BASIC version): http://www.codecguide.com/download_kl.htm
    >Install (decline any freebie stuff so don’t just click next>next without checking)
    >Let it clear out any conflicts automatically and delete any old codecs (Roxio in my case)
    Works!!!! Didn’t have to edit the registry or run the game in ‘XP Compatibility mode’.

  • Our Vultaire, you saved my life, I love this game (to tell the truth is love everything quye Warcraft) and had not found the solution to this in Portuguese yet. Thank you!!! 🙂

  • When I right click on the wc3 icon and go to the Compatibility tab I’m unable to run the program in compatibility with Windows XP, what I’m currently running, because it’s not even listed and there’s no such option as “Disable Desktop Composition” for me to check.

Leave a Reply to Vultaire Cancel reply

Your email address will not be published. Required fields are marked *